Forum rules: Do not post bugs or feature requests here! Report bugs to our Issue Tracker and suggestions to Suggest a Feature.

This site is not for solicitation of services or 'purchasing' development. Please do not post requesting side mods/plugins and so on. Your thread will be removed, and you will receive a warning.
By weezact7
#198236 I'm trying to config my spawning with the Spawn of Psyduck addon. However, I'm experiencing inexplicable instances where it will not reference the spawnofpsy-names file I have in the config folder. It SOMETIMES spawns them correctly, but other times when I load it after changing a pokemon's biome list (Blissey was a big culprit) it will either A) Not spawn any pokemon properly and when I /check them, it reads off default biomes. Other times it will spawn pokemon who are listed before the culprit (alphabetically) correctly, but read only default biomes for those after it. Sometimes it just doesn't spawn any pokemon at all.

- I receive no errors when I start the game, it doesn't generate any errored files.
-I have set UseLegacy and UseModdedBiomes to True

If anyone has any insight into this please let me know, I can't find anything online that isn't years old. I don't know if I can attach my config files to this post to view.
By weezact7
#198271 You may already know this, but perhaps this can narrow your search down:
I've been adjusting the entries one-by-one and checking if they're taken properly. It appears the culprit is Blissey. Every pokemon before Blissey alphabetically consistently works when I change their spawning details. Blissey itself seems to work sometimes (according to /sop check), but nothing after it updates properly. I've tested this repeatedly and it always yields the same result.

I've tried removing Blissey and I've tried copy/pasting one of the working blocks of code and replacing the name with blissey, but neither of those worked.

I'm not sure how this program is coded, but I'd say that perhaps there's a typo or something in the block of code which reads Blissey's stats.

Thank you for your prompt reply. Please let me know if there is anything else I can do to help.
By weezact7
#198273 For anyone else that might experience it. I don't know if I found the cause, but I DID find a workaround. I had two instances where I had typed "Extreme Hills +" (for Boldore and Roggenrola). There should be no space there. Just "Extreme Hills+". Once I corrected those typos, I pasted my altered spawn stats for every Pokemon EXCEPT Blissey and it worked. I then changed Blissey (just to see if I could) and it seems to have taken. So, perhaps the typos were the issues, not poor Blissey.
User avatar
By MoeBoy76
#198277 i'll take a look but i've had reports of Abra not working, it may be a typo but that's unlikely with default Vanilla unless user-added