Pixelmon Mod - Bug tracker

[9.0.0] Starting a raid with multiple people crashes and then freezes the computers of all involved. fix completed

Ticket description:
I was hosting a server with a few friends and one of them decided to try doing a raid alone. When he started the raid he accidentally clicked "Wait for others" and then clicked start. This not only crashed his game but his computer completely locked up. He has a pretty low-end PC so I tried to replicate the problem by starting a raid myself, which worked fine. I later found out that it only worked for me because I didn't click "Wait for others". When I and two of my other friends started a multiplayer raid later that same day, all three of our computers locked up and had to hard restart. I can't provide any screenshots or videos of the event, since, as far as I know, it's impossible to record.

Here is my crash log from the incident:
https://pastebin.com/1VRiP2qV

Comments

#25858 Posted by Katzyn » 01 Jun 2022 02:56

Hey there!

I wasn't able to reproduce this issue with plain ole Pixelmon, and I noticed magnesium in the stacktrace, so I decided to put Magnesium in my mods folder...and ta-da! Crashed. I wasn't lucky enough to get any crash logs with mine, nor did my pc freeze, but I will forward your ticket onto Internal to be looked at by the devs :) Thanks for your report!

#25859 Posted by Katzyn » 01 Jun 2022 04:06

I've done more testing on this, and it seems like it's a combination of altering your graphical settings, being in multiplayer, and using that "wait for others" button. If you remove magnesium and use no other graphical mods, but bump your graphics up to "Fabulous!" do you also still get this issue?

#25870 Posted by ItsPiitchBiitch » 01 Jun 2022 07:52

I removed Magnesium and its dependents and still had the same issue. It also locked my computer up like before, forcing me to hard reset. It's a little bit tricky to reproduce the error, as it doesn't happen every single time you start a raid, nor with rhyme or reason. I've tried changing the distance I stand from the raid den, changing my graphics settings every which way, and even tried in singleplayer, but, given enough tries, it still crashes the same way. The best and only way I've found to test if it's still happening is by just starting a raid the same way over and over again a few times.

#25894 Posted by Katzyn » 01 Jun 2022 23:20

Thanks for the update!

Do you still get crash logs with AND without mods? Could I please get crashlogs WITHOUT mods from you, if possible?

#25911 Posted by Katzyn » 02 Jun 2022 03:23

Okay, with yet more testing, I think I've come to a conclusion - there's at *least* two different crashes happening with raids. I'm gonna write this out here for the sake of transparency, because I might need to make another ticket...

1) There's mine that I mentioned before (erroneously thinking it was what you were reporting) - upping the graphics to Fabulous!, pressing wait for others, then freezing the game but NOT the PC, and latest logs spamming a warning about "Maximum sound pool size 247 reached".

2) And then there's yours - not needing to mess with the graphics just before, pressing the wait for others button, and then HARD crashing your computer, leaving no logs.

I hadn't been able to reproduce the hard crashing involving the computer up until today. I had tested a single raid with a fellow Support, when their PC crashed from it, while mine was fine. (Is the starter of the raid, usually okay?) After they crashed out, I kept interactive with the raid, and I think...3-4 tries later, finally crashed my pc myself.

#25944 Posted by ItsKipz » 02 Jun 2022 20:36

Having the same issue - no messing with graphics settings, complete Windows crash with no crash log, although the client log file for me shows an OpenAL issue: "[Sound engine/ERROR] [net.minecraft.client.audio.ALUtils/]: Stop: Invalid parameter parameter value." (This is also showing up on everyone else in my group who has this issue.) The other crash mentions a sound pool - the issue could be audio-related?

If it helps for testing purposes it's happening with users who both have additional "performance" mods (i.e. Magnesium), and users who do not - I can provide debug logs if they could be helpful, although they don't display anything that seems out of the ordinary aside from that OpenAL error

#25948 Posted by Katzyn » 02 Jun 2022 20:57

As far as I've seen, the " Stop: Invalid parameter parameter value." message is posted after every battle a player has (at least with a wild pokemon), so I'm not sure. With the less-severe (game-only) crash, I suppose it's possible?

At this point, I just need more information.

Can everyone who gets this issue please try to reproduce using only default Pixelmon - no mods, no changing configs or anything, and if you can reproduce it, send me all logs from that - server, latest, debug, etc?

#25951 Posted by ItsPiitchBiitch » 02 Jun 2022 22:15

I tried today in singleplayer with just Pixelmon and no other mods and after about 20 successful raids I can say with 99% certainty that it's a conflict with another mod. Since so many others are having the issue, however, I can only guess it's a pretty popular mod that everybody uses.

#25991 Posted by ItsKipz » 03 Jun 2022 14:53

I was not able to reproduce the issue at all in singleplayer using just Pixelmon and a standard set of performance mods (the same ones that I was using when the crash happened on a server) so I also started up a dedicated server to test if the issue was caused by running in multiplayer - this was able to reproduce the issue almost instantly. (As a side note, I was also able to confirm that quickly killing the instance in MultiMC prevents it from crashing my computer entirely, and it "unlocks" when the instance closes - I also noticed that audio continues to play from the instance when it freezes, and this continues until Windows eventually locks up completely, so the game is still running fine just unable to update visually)

Testing with just Pixelmon on both the client and the server about 15 times, the issue did not appear, so I added back the performance mods one by one (only on the client, the server never had any extra mods even when the issue was occurring) - the issue seems to occur when the Helium performance mod is installed on the client, even if it is the only mod installed besides Pixelmon itself . I'm attaching the server and client's latest.log and debug.log (there was no crash report to attach, since the game itself doesnt crash, only freeze) both with verbose turned on and off on both ends: https://drive.google.com/drive/folders/1dVdXT6DVqrZrU0aoE0-YzJJg6FFcDKEF?usp=sharing

I also tested a much more complete set of mods with multiple performance and content mods, the original pack I was using when the issue started, and removing Helium seemed to fix the issue completely.

TL;DR - Helium on the client appears to be the cause, using all the other performance and content mods I was using when the crash first happened seems fine

#25995 Posted by ItsKipz » 03 Jun 2022 16:18

Update: I'm also having what seems to be a different but related issue - the same exact crash happens (even with Pixelmon is the ONLY mod used on the server and clients) if a raid is started with multiple players, and sometimes even just if another player is nearby. The log files from both server and client (verbose and not verbose both included) are attached here: https://drive.google.com/drive/folders/ ... sp=sharing

Ticket details

  • Ticket ID: 17787
  • Project: Pixelmon Mod
  • Status: Fix completed
  • Component: Crash
  • Project version: 1.16.5-9.x.x
  • Priority: Normal
  • Severity: Normal
  • Forge/Sponge: (unknown)
  • What else would be useful to know?: (unknown)
  • Assigned to: Katzyn
  • Reported by: ItsPiitchBiitch (Send PM)
  • Reporter's tickets: (List all tickets)
  • Reported on: 28 May 2022 19:11
  • Ticket last visited by: Sophie847 on 29 Jun 2022 03:12
JOIN THE TEAM