Pixelmon Mod - Bug tracker

[9.0.2 1.16.5] Starting lots of battles in a short amount of time causes issues w/ battle music pending

Ticket description:
By starting up & ending (running/forfeiting) lots of battles in a short amount of time, the battle music starts to bug out:
https://youtu.be/pu4ulBZ-j5c

It *seems* to be caused initially when you enter a battle, quickly leave it, then quickly enter another battle before the 1st battle's music has "unregistered" so to speak. As an example:
https://youtu.be/r9yPS_9C3w8

In this 2nd video I did a battle normally, no issue as you can see. Then, I did another battle but waited a couple seconds after the first battle to start another one. Music still behaves properly. Finally, I started a battle, ran from it, and before the music from the 1st battle could finish I started another battle. After leaving that last battle, the music started outside of the battle and the only way to stop it was to disconnect/re-connect.

Let me know if this is understandable and/or if you need any further info from me. Thanks!

Comments

#26461 Posted by Katzyn » 21 Jun 2022 06:30

Thank you for the report! I will link this to an existing Internal ticket made a few weeks ago :)

Ticket details

  • Ticket ID: 18237
  • Project: Pixelmon Mod
  • Status: Pending
  • Component: Battle
  • Project version: 1.16.5-9.x.x
  • Priority: Normal
  • Severity: Normal
  • Forge/Sponge: 36.2.34
  • What else would be useful to know?: (unknown)
  • Assigned to: Katzyn
  • Reported by: HatTrickPatrick (Send PM)
  • Reporter's tickets: (List all tickets)
  • Reported on: 18 Jun 2022 18:17
  • Ticket last visited by: Katzyn on 31 May 2023 01:15
JOIN THE TEAM