Join our discord
In partnership with NodeCraft Logo NodeCraft


You are not logged in! Create an account or login to contribute! Log in here!
From Pixelmon Wiki
This page is a translated version of the page Installation and the translation is 0% complete.

Other languages:
Deutsch • ‎English • ‎español • ‎français • ‎italiano • ‎português do Brasil • ‎čeština • ‎русский • ‎中文(中国大陆)‎

This is a guide for installing the Pixelmon mod through one of the many supported launchers. This guide and its sub-pages will cover installing Pixelmon to a client, for use in single player or for playing on servers. If you want to create a server, please see our server installation guide instead.

Requirements

  • A paid copy of the Java edition of Minecraft, as purchased from this link or through your Mojang account.
    • Only the Java edition can run Forge mods such as Pixelmon. Other editions (Pocket, Windows 10, console releases) cannot run Forge!
    • Cracked launchers may not save your Pokémon when you quit Minecraft, or may cause other issues. This will not be fixed.
  • A 64-bit build of Java 8, or a launcher that has a copy of Java bundled in. Newer Java versions will not work with Minecraft 1.12.2.
  • At least 2 GB of available and assignable RAM.

Notes

  • If Minecraft is currently running, quit out of it before installing anything. Close any open launchers as well.
  • If you are installing other mods alongside Pixelmon, check the incompatibilities list first to avoid issues.

Launchers

Minecraft, by default, comes with a launcher program that will allow you to log into your account and manage your different installations. While this works well for the base game, installing Forge and its mods can be a difficult process. As such, you can find pre-built Pixelmon packs on several custom launchers that will automatically install everything you need to get playing.

The table below covers the most common launchers. Click one of the launcher links to see how to install Pixelmon to it.

Launcher Advantages Disadvantages
Minecraft (default) Reliable, built-in Java, supports MS accounts Difficult install, no pack support (manual adding/updating of mods)
ATLauncher (recommended) Reliable, built-in Java, supports MS accounts Slightly clunky interface
Technic Easy, lots of modpacks available Wipes custom mods when updating a pack
CurseForge Easy, lots of modpacks available Downloading big mods like Pixelmon may fail, large bundled install

Please note: You may also need to allocate more memory to make Pixelmon and other mods run correctly, as covered in our allocation guide.

Versions

Pixelmon is compatible with several versions of Minecraft, shown in the table below. Note that Pixelmon currently targets the 1.12.2 version of Minecraft, with older versions of Minecraft being considered legacy and no longer receiving updates, bug fixes or support.

Minecraft version Pixelmon version
1.12.2 8.1.2
1.10.2 5.1.2
1.8.9 4.3.1
1.8 4.1.4
1.7.10 3.5.1

Troubleshooting

  • If Minecraft crashes after installing Pixelmon, start by examining the crash report using this crash reading guide.
  • If Minecraft never finishes loading or runs poorly, you may need to give it more memory. See this guide for instructions on resolving the issue.
  • If you require further help, drop by the Pixelmon Discord (recommended) or post a ticket explaining the problem to our support tracker.

Video tutorials

macOS

© 2014 - 2020 Pixelmon Mod