In partnership with NodeCraft Logo NodeCraft

From Pixelmon Wiki
Revision as of 14:54, 29 December 2016 by Some body (talk | contribs)

For crashes related to the Pixelmon launcher before starting Minecraft, see this page.

So I herd you liek crashing? Well good! I am here to help to fix those pesky crashes! Welcome to Crash Reading 101. A "crash" course! Minecraft runs very specifically especially when installing mods and the smallest error, as you know, can cause the mod to crash! >:( But do not fret! I am here to help! Let's start. Here I have gathered a bunch of crashes around the Pixelmon forums and compiled them into one universal tutorial anyone can understand!

Crash reports

The following messages are found under the section that says "Description" near the top of the report. Each bullet point is a separate crash report.

Version 5.0.x

  • "java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/..."
  • "SplashProgress has detected a error loading Minecraft."
  • "Caused by: java.lang.IllegalAccessError: tried to access field net.minecraft.client.renderer.entity.RenderManager.field_178636_l from class com.pixelmonmod.pixelmon.client.ClientProxy"

You haven't allocated enough memory to Minecraft. In the JVM arguments in your Minecraft profile, find the "-Xmx512M" or "-Xmx1G" argument and change it to "-Xmx2G". If this doesn't change anything, see this page. If you have a 32-bit operating system or Java version, you will need to upgrade to 64-bit to allocate sufficient memory.


  • "Caused by: java.lang.NoSuchMethodError: com.pixelmonmod.pixelmon.items.PixelmonItemBlock.func_77655_b(Ljava/lang/String;)Lnet/minecraft/item/ItemBlock;"

You need to use Minecraft 1.10.2 with this version of Pixelmon.


  • "java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/items/ItemBlock"

Gameshark is incompatible with this version of Pixelmon. You will need to remove Gameshark until it is updated to be compatible.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/shaded/ninja/leaping/configurate/loader/ConfigurationLoader"

Gym Wars 2: Feebas Unleashed is incompatible with this version of Pixelmon. You will need to remove this sidemod until it is updated to be compatible.

Version 4.3.x/4.2.x

  • "java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraft.client.renderer.StitcherException: Unable to fit: missingno - size: 16x16 - Maybe try a lowerresolution resourcepack?"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/..."
  • "net.minecraftforge.fml.client.SplashProgress$5: java.lang.IllegalStateException: Splash thread"
  • "SplashProgress has detected a error loading Minecraft."

You haven't allocated enough memory to Minecraft. In the JVM arguments in your Minecraft profile, find the "-Xmx512M" or "-Xmx1G" argument and change it to "-Xmx2G". If this doesn't change anything, see this page. If you have a 32-bit operating system or Java version, you will need to upgrade to 64-bit to allocate sufficient memory.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelmonmod.pixelmon.Pixelmon"

You need to update your Java version to Java 8.


  • "org.lwjgl.LWJGLException: Pixel format not accelerated"

Your graphics card is incompatible with Minecraft. There are several different causes and corresponding solutions to this issue; try this page.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.IllegalAccessError: tried to access field net.minecraft.client.renderer.entity.RenderManager.field_178636_l from class com.pixelmonmod.pixelmon.client.ClientProxy"

Make sure you did not extract or unzip the contents of the Pixelmon jar; place the entire jar into the mods folder. If you have already done this correctly, check if your Pixelmon jar's extension is ".jar.zip"; if so, change the extension to ".jar". If you do not see the ".zip" extension, you may need to have extensions showing on your system; a tutorial on how to do so can be found here.


  • "java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/items/ItemBlock"

GameShark is incompatible with this version of Pixelmon. You will need to remove GameShark until it is updated to be compatible.

Version 4.1.x

  • "java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/..."
  • "net.minecraftforge.fml.client.SplashProgress$5: java.lang.IllegalStateException: Splash thread"
  • "net.minecraft.client.renderer.StitcherException"

You haven't allocated enough memory to Minecraft. In the JVM arguments in your Minecraft profile, find the "-Xmx512M" or "-Xmx1G" argument and change it to "-Xmx2G". If this doesn't change anything, see this page. If you have a 32-bit operating system, you will need to upgrade to a 64-bit operating system to allocate sufficient memory.


  • "Could not reserve enough space for...object heap"

If you have a 32-bit operating system, you cannot allocate 2G RAM or more to Minecraft. Try reducing the amount of allocated RAM to 1G. If the results of this are unsatisfactory (e.g., crashing, low FPS), you will need to upgrade to a 64-bit operating system to allocate more RAM to Minecraft.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/common/util/EnumHelper"
  • "java.lang.NoClassDefFoundError: net/minecraftforge/client/model/ItemLayerModel"

Use the recommended Forge version listed on the Pixelmon downloads page.

  • "net.minecraftforge.fml.common.WrongMinecraftVersionException: Wrong Minecraft version for pixelmon"

You need to use Minecraft version 1.8 to use Pixelmon.

Version 4.0.x

  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/entities/npcs/EntityTrainer"

Remove Trainer Commands from your Pixelmon launcher profile and re-add it.


  • "java.lang.OutOfMemoryError: Java heap space"
  • "java.lang.OutOfMemoryError: GC overhead limit exceeded"
  • "java.lang.OutOfMemoryError: Rendering Block Entity"
  • "java.lang.IllegalStateException: Splash thread"
  • "net.minecraft.client.renderer.StitcherException"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.OutOfMemoryError: Java heap space"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: com/pixelmonmod/pixelmon/..."

You haven't allocated enough memory to Minecraft. In the JVM arguments in your Minecraft profile, find the "-Xmx512M" or "-Xmx1G" argument and change it to "-Xmx2G". If this doesn't change anything, see this page. If you have a 32-bit operating system, you will need to upgrade to a 64-bit operating system to allocate sufficient memory.


  • "org.lwjgl.LWJGLException: Pixel format not accelerated"

Your graphics card is incompatible with Minecraft. There are several different causes and corresponding solutions to this issue; try this page.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/client/model/IModel"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/client/model/ModelLoader"
  • "net.minecraftforge.fml.common.LoaderException: java.lang.NoSuchMethodError: net.minecraftforge.client.model.ModelLoader.setCustomStateMapper(Lnet/minecraft/block/Block;Lnet/minecraft/client/renderer/block/statemap/IStateMapper;)V"
  • "java.lang.NoClassDefFoundError: net/minecraftforge/common/util/EnumHelper"

Use the recommended Forge version listed on the Pixelmon downloads page.


  • "java.lang.NoClassDefFoundError: cpw/mods/fml/relauncher/IFMLLoadingPlugin"

Don't use Minecraft 1.7.10 mods with Minecraft 1.8.


  • "java.lang.RuntimeException: org.lwjgl.LWJGLException: Could not create context (WGL_ARB_create_context)"

Open the "splash.properties" file in the config folder and disable the Forge splash screen.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelmonmod.pixelmon.Pixelmon"

Don't extract or unzip the Pixelmon jar. Place the jar itself in the mods folder instead.


  • "net.minecraftforge.fml.common.LoaderException: java.lang.IllegalAccessError: tried to access field net.minecraft.client.renderer.entity.RenderManager.field_178636_l from class com.pixelmonmod.pixelmon.client.ClientProxy"
  • "java.lang.IllegalAccessError: tried to access field net.minecraft.entity.projectile.EntityFishHook.field_146055_aB from class com.pixelmonmod.pixelmon.entities.projectiles.EntityHook"

If you are using Windows, rename the Pixelmon jar from ".jar.zip" to ".jar". If you do not see the ".zip" extension, you need to have extensions showing on your system; a tutorial on how to do so can be found here.

If you are using Mac OS X, do not unzip the Pixelmon jar. Place the jar itself in the mods folder instead.

Version 3.5.x

  • at java.nio.Buffer.checkIndex(Buffer.java:540)
  • at java.nio.DirectIntBufferU.get(Unknown Source)

Lower your render distance to 16 chunks or less.

  • "cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/event/world/BlockEvent$PlaceEvent"

Use the Forge version recommended on the Pixelmon downloads page.

  • "java.lang.OutOfMemoryError: Java heap space"
  • "java.lang.OutOfMemoryError: Initializing game"
  • "net.minecraft.client.renderer.StitcherException: Unable to fit: missingno - size: 16x16 - Maybe try a lowerresolution resourcepack?"

You haven't allocated enough memory to Minecraft. In the JVM arguments in your Minecraft profile, find the "-Xmx512M" or "-Xmx1G" argument and change it to "-Xmx2G". If this doesn't change anything, see this page. If you have a 32-bit operating system, you will need to upgrade to a 64-bit operating system to allocate sufficient memory.

Version 3.4.x

  • "cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/event/world/BlockEvent$PlaceEvent"
  • "java.lang.NoSuchMethodError: net.minecraftforge.common.util.EnumHelper.addArmorMaterial(Ljava/lang/String;Ljava/lang/String;I[II)Lnet/minecraft/item/ItemArmor$ArmorMaterial;
  • "at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_31]"

Use the Forge version recommended on the Pixelmon downloads page.


  • "at java.nio.Buffer.checkIndex(Buffer.java:540)"
  • "at java.nio.Buffer.checkIndex(Buffer.java:512)"
  • "at java.nio.Buffer.checkIndex(Unknown Source)"

Lower your render distance to 16 chunks or less.

Version 3.3.x

  • "at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.8.0_25]"

Use the Forge version recommended on the Pixelmon downloads page.


  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelmonmod.pixelmon.Pixelmon"

Do not extract the Pixelmon jar file. Place the entire downloaded file directly into the mods folder.


  • "at java.nio.Buffer.checkIndex(Unknown Source)"

Lower your render distance to 16 chunks or less.


  • "java.lang.UnsupportedClassVersionError: coloredlightscore/src/asm/ColoredLightsCoreLoadingPlugin : Unsupported major.minor version 51.0"
  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelutilities.Basemod"
  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pqqqqq.spawnofpsyduck.SpawnOfPsyduck"

Both PixelUtilities and Spawn of Psyduck require Java 7 or 8 to function and will not work with Java 6.


  • "cpw.mods.fml.common.MissingModsException"

If you are using Wawla, you need to install Waila, Not Enough Items, and CodeChickenCore in order for it to work.


  • "at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:146)"

Add "-Djava.net.preferIPv4Stack=true" to your VM args in the profile you are using. This is found on the Minecraft launcher.

Version 3.2.x

  • "cpw.mods.fml.common.LoaderException: java.lang.NoSuchFieldError: field_150354_m"
  • "java.lang.NoClassDefFoundError: net/minecraftforge/common/util/EnumHelper"

You have the wrong Minecraft and/or Forge version. Pixelmon 3.2 is for Minecraft 1.7.10 using a version of Forge that is at least 10.13.0.1187.


  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelmonmod.pixelmon.Pixelmon"

Do not extract the Pixelmon jar file. Place the entire downloaded file directly into the mods folder.


  • "at java.nio.Buffer.checkIndex(Unknown Source)"

Lower your render distance to 16 chunks or less.


  • "at cpw.mods.fml.common.Loader.preinitializeMods(Loader.java:507)"

You have multiple copies of Pixelmon inside the mods folder. Remove all but one copy.


  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pqqqqq.spawnofpsyduck.SpawnOfPsyduck"

Spawn of Psyduck does not work with Java 6. Update to Java 7 or Java 8.


  • "at com.pixelmonmod.pixelmon.sounds.Sounds.clearMusic(Sounds.java:90)"

Delete the Pixelmon.h2.db file in the database folder.


  • "Mod rejections [FMLMod:pixelmon:(3.2.x)]"

Your version of Pixelmon must match the version of Pixelmon that is on the server you are trying to join.


  • "java.lang.ClassCastException: com.pixelmonmod.pixelmon.client.camera.EntityCamera cannot be cast to net.minecraft.client.entity.EntityPlayerSP"

Do not use Optifine with this version of Pixelmon.


  • "at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:146)"

Add "-Djava.net.preferIPv4Stack=true" to your VM args in the profile you are using. This is found on the Minecraft launcher.


  • "at com.mojang.util.UUIDTypeAdapter.fromUUID(UUIDTypeAdapter.java.22)"

You have a cracked account and are trying to join a premium server. Buy Minecraft.

Version 3.1.x

  • "java.lang.IllegalStateException: cannot determine the type of the type parameter 'REQ': class cpw.mods.fml.common.network.simpleimpl.SimpleChannelHandlerWrapper"
  • "java.lang.NoClassDefFoundError: net/minecraftforge/common/util/EnumHelper"
  • "java.lang.NoSuchMethodError: net.minecraft.client.gui.ScaledResolution.<init>"
  • "at com.google.common.base.Preconditions.checkNotNull(Preconditions.java:192)"
  • "java.lang.NoSuchMethodError: com.google.common.collect.Multimaps.filterValues(Lcom/google/common/collect/SetMultimap;Lcom/google/common/base/Predicate;)Lcom/google/common/collect/SetMultimap;"

All of these errors occur with incorrect versions of Minecraft and/or Forge being used. Make sure you are running Minecraft 1.7.2 and either Forge 10.12.2.1121 or 10.12.2.1147.


  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: com.pixelmonmod.pixelmon.Pixelmon"

Do not extract the Pixelmon jar file. Place the entire downloaded file directly into the mods folder.


  • "java.lang.RuntimeException: Unknown character ' ' in"

Delete your Pixelmon.cfg file.


  • "at cpw.mods.fml.common.Loader.preinitializeMods(Loader.java:506)"

You have multiple Pixelmon jars in the mods folder. Only one Pixelmon jar should be in the mods folder at once.


  • "at com.pixelmonmod.pixelmon.sounds.Sounds.clearMusic(Sounds.java:90)"

Delete the Pixelmon.h2.db file in the database folder.


  • "at net.minecraft.server.MinecraftServer.<init>(MinecraftServer.java:140)"
  • "at net.minecraft.client.Minecraft.func_71371_a(Minecraft.java:2088)"

Add "-Djava.net.preferIPv4Stack=true" to your VM args in the profile you are using. This is found on the Minecraft launcher.

Version 3.0.x

  • "java.lang.NoClassDefFoundError: cpw/mods/fml/common/ICraftingHandler"
  • "cpw.mods.fml.common.LoaderException: java.lang.NoClassDefFoundError: net/minecraftforge/client/event/RenderGameOverlayEvent$Chat"
  • "java.lang.NoSuchMethodError: net.minecraft.launchwrapper.LaunchClassLoader.clearNegativeEntries(Ljava/util/Set;)V"
  • "java.lang.VerifyError: Bad type on operand stack"
  • "java.lang.VerifyError: (class: pixelmon/Pixelmon, method: onServerStart signature: (Lcpw/mods/fml/common/event/FMLServerStartingEvent;)V) Incompatible argument to function"

You have the wrong version of Minecraft, Forge, or both. Pixelmon 3.0.4 runs on Minecraft 1.6.4 using Forge version 9.11.1.965.


  • "cpw.mods.fml.common.LoaderException: java.lang.ClassNotFoundException: pixelmon.Pixelmon"

Do not extract the Pixelmon jar file. Place the entire downloaded file directly into the mods folder.


  • "java.lang.RuntimeException: Unknown character ' ' in"
  • "java.lang.RuntimeException: Unmatched quote in '/config/pixelmon.cfg:175'"

Delete the Pixelmon.cfg file.


  • "at pixelmon.sounds.Sounds.addPokemonSound(Sounds.java:106)"
  • "at java.util.ArrayList$Itr.checkForComodification(ArrayList.java:901)"

Java 8 does not normally work with this version of Forge. You can use the Legacy Java Fixer to fix this issue.


  • "at net.minecraft.block.Block.<init>(Block.java:349)"

You have item ID conflicts between mods. Modify the offending item IDs or remove the mods that are causing the problem.


  • "at net.minecraft.client.gui.inventory.GuiContainer.func_73863_a(GuiContainer.java:123)"

Not Enough Items does not work with this version of Pixelmon.

Console Errors

  • "[Client thread/ERROR]: 1286: Invalid framebuffer operation"
  • Blank screen except for a small rectangle in the bottom-left of the window.

This is a bug with older versions of Forge. Either update to at least Forge 10.13.2.1226 or add "-Dforge.forceNoStencil=true" to the JVM arguments in your Minecraft profile.


  • "[Client thread/WARN]: Unable to play unknown soundEvent: pixelmon:pixelmon.mob."
  • "[Client thread/ERROR] [FML]: Model definition for location pixelmon:"
  • "java.io.FileNotFoundException: pixelmon:textures/blocks/"

These console errors are normal. Nothing has to be done if you see these errors.


  • "WARNING: Failed to mark a promise as success because it is done already: [email protected]"

This is a bug in Netty and the issue related to it can be found here.


If your crash report doesn't match any of these issues, post the full report in the support tracker.

© 2014 - 2019 Pixelmon Mod